てきとうなさいと べぇたばん

このサイトのPHPを7.3から7.4にアップグレードしました

TOP > てきとうにこらむ > このサイトについて。 > このサイトのPHPを7.3から7.4にアップグレードしました

PHP 7.4.18にアップグレードしました。しかし、7.4.19が出てるんですよね…

このサイトのPHPを7.3から7.4にアップグレードしました

ちょっとバージョンも古くなってきたので、7.4にアップグレードしました。 ハマったところがあったりと少し苦労しました。

動機としては、バグを発見したことで、それが反映されたバージョンが、7.4.18と8.0.5なのでというのがあります。

ハマったところ

GD周りですね。

--with-gdが、--enable-gdへと変更された
-with-png-dir=DIRと--with-zlib-dir[=DIR] が必要なくなった
必要なくなったが、libpngとzlibは必須になった。

また、jpeg周りも違いが発生しています。

--with-jpeg-dir=DIRが、--with-jpegへと変更された

こういう部分がないとimagejpegとかが見つからなくてあれ?ってなったりするので注意しましょうね…

参考サイト